Ipad Installer Frash sur iPad

15 1762

[ATTENTION] Dernier Frash : 0.02 => Compatible iOS 4.0 / 4.1, Incompatible avec iOS 4.2.x ! Veuillez consulter les commentaires pour les (pseudos) alternatives.

Comme nous vous l’annoncions dans un précédent article, Flash est dorénavant disponible sur iPad sous le nom de Frash.

Si vous souhaitez installer Flash sur votre iPad jailbreaké, voici la méthode :

  1. Jailbreakez votre iPad (si ce n’est déjà fait) (ici si ce n’est pas le cas avec spirit)
  2. Téléchargez le fichier Frash.deb (Google est ton ami, mais pour les plus fainéants voici un début de piste ici )
  3. Il faut ensuite rajouter le fichier frash.deb sur votre iPad.
  4. Pour les utilisateurs de Mac :
    • Installez Netatalk en effectuant une recherche sur Cydia.
    • Une fois Netatalk installé, redémarrez l’iPad.
    • Branchez-le sur votre mac et vous devriez voir apparaitre une petite icône iPad dans la partie Partage.
    • Connectez-vous avec les identifiant suivant : root et alpine

    Pour les utilisateurs de Windows :
    Suivez les instructions sur le lien suivant (ici)

  5. Une fois que vous avez accès aux dossiers de votre iPad, accédez  à /var/root/Media
  6. A l’intérieur de Media créez un dossier Cydia
  7. A l’intérieur du dossier Cydia, créez un dossier AutoInstall
  8. Placez le fichier frash.deb à l’intérieur du dossier AutoInstall
  9. Redémarrez l’iPad et déconnectez-le de votre mac
  10. Essayez de naviguer sur des sites en Flash. L’icône Flash va apparaitre mais en appuyant dessus, vous devriez pouvoir avoir accès au contenu.

La méthode n’est pas encore parfaite et il n’est pas rare de voir quelques plantages. Exemple ci-dessous avec le site de M6 et l’émission l’amour est dans le pré

Frash Flash iPadFrash Flash iPad

15 commentaires

  1. j’ai vraiment suivi toutes vos indications pour installer Frash et, ça ne fonctionne pas, je ne comprends pas…. Quelqu’un peut-il m’aider?…
    D’avance, merci.

    • Désole mais j ai bien tout fait et ça ne marche pas il m affiche une erreur. Le plugin frash.deb 002 est bien dans le dossier autoinstall. Le mot flash s affiche sur les contenus en flash mais pas l icône rouge et quand je clique dessus, il affiche une erreur. Par contre impossible de télécharger frash.deb directement danscydia comme indique dans le tuto. Y a t il une version plus récente de frah?

      • 1) Vérifiez la casse, minuscules / majuscules, autoinstall n’est pas pareil que AutoInstall
        2) Attention aux faux frash qui circulent sur Internet, vérifiez la source où vous le téléchargez (d’abord le lien que j’ai mis à jour dans l’article pour la 0.01), au pire essayez en plusieurs trouvés avec Google grâce à la recherche “frash iPad”, montez dans les versions jusqu’à la 0.02 (la dernière), ça dépend de la compatibilité
        3) Mettez les droits en lecture et écriture (les deux c’est important) s’ils n’y sont pas sur le dossier AutoInstall lui-même est les fichiers en .deb dedans après que vous les ayez mis (sur Mac dans le Finder, menu “Fichier > Lire les informations”)
        4) Essayez différents sites avec du flash, ce n’est pas encore une solution stable

    • Frash actuellement (même la 0.02) est incompatible avec iOS 4.2.1 (veuillez m’excuser, je n’avais pas encore remarqué, en fait je me passe du flash…), il y a des navigateurs payants sur l’App Store, Skyfire et iBitfire par exemple, qui transcodent les vidéos flash sur des serveurs distants pour pouvoir les lire si le site est pris en charge (les vidéos sans streaming, pas les contenus interactifs) mais bon… techniquement c’est encore de la bidouille… et je ne donnerai pas de lien pour les navigateurs, parce que… je trouve que cela ne marche pas…

      • C’est quand meme important de le mentionner… C’est quand meme le dernier os et je pense que beucoup de monde travaille avec cet ios !!! Donc si je comprends bien, ton truc ne sert pas …

        Dommage

        • Oui. Ca doit être la majorité, l’article est de Juillet 2010 et n’avait pas suivi l’évolution d’iOS, j’ai bien marqué en rouge dans l’article maintenant.

          [Mode blague] Si si il y a des personnes avec de “vieux” iPad qui préfèrent downgrader leur iOS en 4.1 (par une manipulation compliquée…) et avoir un pseudo flash que de profiter d’iOS 4.2.x, [/Mode blague]… en fait tu as raison ;-)

          Sur iOS 4.2.x (payants, c’est surtout le coût du service qui convertit les vidéos) :

          - Skyfire :
          http://itunes.apple.com/fr/app/skyfire-navigateur-pour-ipad/id409153623?mt=8

          - iBitfire :
          http://itunes.apple.com/fr/app/ibitfire/id402520084?mt=8

          => pas de streaming (megavideo, wat.tv, etc.), pas de contenus interactifs (avec menus, jeux, etc.), que des sites “connus” (jeuxvideo.fr, etc.), c’est lent (quand ça marche, le temps de la conversion)
          Note: on ne répondra pas aux commentaires à propos de ces applications, elles sont simples, pour chaque vidéo de site soit ça marche soit ça ne marche pas ! merci pour votre compréhension

          C’est la seule chose (pour l’instant) que l’on peut proposer pour le dernier iOS (4.2.x)…

          Merci pour tes commentaires ;-)

  2. comme j,ai le 4.2.1 ca marche pas. dommage car naviger sans flash c est galere j ai fait un site en flash que je peux mm pas voir. pas d upgrade pour le moment? que fait la police? et apple qui resiste pourquoi? probleme de $$$. zarbi car adobe etait un partenaire d apple historique.

    • En fait, Apple a un positionnement assez ambiguë à mon avis. On pourrait penser qu’ils veulent faire augmenter l’utilisation des standards du Web en voulant enlever flash, mais ils veulent que la presse fasse des applications natives pour leurs appareils, ce qui est contraire à l’esprit universel du Web. Cependant c’est vrai qu’il y a des fonctionnalités de ses applications natives qui ne sont pas encore entièrement normalisées dans HTML 5, donc pas vraiment utilisables en production à lancer sur tous les appareils mobiles (chaque navigateur ayant un comportement différent).

      Donc, le seule chose que je comprends c’est qu’ils veulent que leurs appareils ne perdent pas vite de la batterie, pour les utilisateurs qui ne savent pas ce qu’est flash. Sur le Mac, l’utilisation de flash est très lourde pour les petites configurations, il suffit de télécharger le flux d’une video (je reviendrai sur ce cas à la fin) et de le faire lire à VLC pour voir que ça devient totalement fluide, flash n’est pas optimisé dans ce cas. Et ce n’est que dernièrement, que flash utilise le “processeur graphique” (GPU) dédié et plus efficace pour ce genre de tâches, seulement sur les composants graphiques compatibles par contre. Sur les iDevices, si on fait le parallèle, le point de vue du patron d’Apple est assez recevable pour ça mais je pense que c’est un prétexte pour quelque chose de plus commercial. Ce qui est assez bizarre puisque beaucoup de graphistes sont historiquement sur Mac et utilisent des solutions Adobe, mais… c’est le Mac, pas les iDevices même si c’est Apple.

      Finalement je pense que c’est pour inciter (obliger même) au développement de solutions spécifiques, exclusives avec de la plus value pour l’utilisateur final. Ca ressemble à une position de monopole dans le principe parce que l’on ne peut pas demander à une solution minoritaire de ne pas s’ouvrir, sinon c’est la mort assurée. Je crois qu’ils pensent qu’à l’utilisateur final dans le principe de la convention : “Faut faire par défaut ce qui convient à la majorité” et ne pas rendre iOS extensible parce que ce n’est pas la cible du marché principale, en gros ils vont sur Android. Là dessus iOS est très différent de Mac OS X, et c’est le reproche principal des utilisateurs de mon point de vue. En gros pour résumé, ils pensent que l’expérience pour le Web est meilleure pour la majorité des utilisateurs sans flash parce que le plug-in flash est trop lourd trop souvent. Ils oublient que flash ne se résume pas à la vidéo, mais la majorité des utilisateurs pensent seulement aux bannières de pub et aux vidéos, pas à l’utilisation d’ActionScript dans flash…

      Ce qu’ils préconisent :
      - vidéos : balise video de l’HTML 5
      - animation : balise canvas de l’HTML 5, annoncé par un collaborateur Adobe mais pas encore sorti…
      - interactivité : re-coder en CSS / Javascript, c’est assez accessible pour des choses avec simplement des menus, mais ça devient un véritable boulot pour un développeur Web sinon.

      Apple n’a aucun contrôle sur flash, juste accepter, caricaturalement ils ont préféré jeter bébé avec l’eau du bain… Pour l’instant, il faut déployer une application iOS spécifique pour un projet en flash avec Adobe Flash CS5.

  3. Et ben bien deg… Font chier Apple!!! J’ai jaillbreacker mon iPad aujourd’hui en pensant pouvoir installer frash.. Et voila bloquer a cause de 4.2.1!

Laisser une réponse